Primele aplicatii compatibile doar cu iOS 5 apar in App Store

3

   Una dintre principalele probleme ale posesorilor de iDevice-uri mai vechi de doi ani este imposibilitatea de a instala unele aplicatii compatibile doar cu o noua versiune a iOS. Spre exemplu posesorii de iPhone 3G nu puteau instala in primavara aplicatii compatibile doar cu iOS 4.3 iar acum avem deja primele aplicatii compatibile doar cu iOS 5. Numarul lor este mic insa in curand in App Store vor fi disponibile din ce in ce mai multe aplicatii de acest gen iar cei care nu a facut update la ultima versiune a sistemului de operare nu le vor putea instala.

    Ratiunea din spatele acestei limitari in compatibilitate este simpla: este mult mai usor sa faci o aplicatie doar pentru o anumita versiune a sistemului de operare. Extinderea compatibilitatii si la versiunile vechi implica multa munca de codare si unii dezvoltatori prefera sa nu faca acest lucru in ideea de a avea o aplicatie cat mai buna din punct de vedere al performantelor. Din pacate pana la sfarsitul anului vor fi disponibile si aplicatii/jocuri noi care nu vor functiona pe iOS 4 asa ca ar fi bine sa va ganditi la un upgrade la iOS 5, daca il puteti face.