iOS 6 aduce moartea iPhone 3G, dezvoltatorii nu vor mai putea produce...

iOS 6 aduce moartea iPhone 3G, dezvoltatorii nu vor mai putea produce aplicatii compatibile cu el

  Daca inca va aflati in randul putinelor persoane care detin un iPhone 3G, atunci va anunt ca dispozitivul vostru va deveni complet irelevant pentru dezvoltatori de indata ce iOS 6 va fi oficial lansat si va avea o versiune actualizata a Xcode. Apple a inceput de mult sa scoata din Xcode framework-urile care sunt necesare pentru ca aplicatiile sa functioneze pe iPhone 3G, iar Xcode-ul pentru iOS 6 va ramane complet fara aceste framework-uri si dezvoltarea de aplicatii compatibile cu iOS 6 va deveni imposibila.

The iPhone 3G has been discontinued 2 years ago. But there is also a technical reason why 2012 will be the final nail in the coffin that buries the iPhone 3G: The deprecation of armv6. The discontinuation of support for armv6 has been already a year in the making. In Xcode 4.3 Apple had already removed the armv6 setting from the ARCHS_STANDARD_32_BIT, that was strike one. I argue by accident because at that time you still had to submit so-called “fat binaries” that have compiled code for armv6 and armv7 in the same file. From that point on you had to manually add the armv6 setting to the Architectures in Build Settings.

  Xcode-ul nu va mai oferi dezvoltatorilor posibilitatea de a produce aplicatii care sa suporte o versiune de iOS mai mica decat 4.3, iar iPhone 3G poate instala doar iOS 4.2.1, deci cu asta se incheie viata 3G-ului. Daca inca detineti un asemenea dispozitiv, ar fi recomandabil sa il vindeti si sa cumparati un model mai recent al iPhone, altfel nu veti mai putea utiliza noile aplicatii. La final trebuie sa remarc faptul ca iPhone 3G are 4 ani vechime si decizia aceasta este perfect normala, avand in vedere ca dezvoltarea de aplicatii compatibile cu sisteme atat de vechi este foarte dificila.

REDUCERI PENTRU JUCARII DE ZIUA COPILULUI!

13 COMENTARII

  1. oricum, dupa statisticile de pe net, inca de acum multe luni, procentul de iOS 5) era complet nejustificat fata de nr de posibili clienti.

    RIP.

  2. In momentul asta este destul de greu sa faci aplicatii compatibile cu iOS >3.1.3. Storyboard-ul, adica locul unde faci design-ul aplicatiei foarte rar se intampla sa nu dea eroare daca compatibilitatea aplicatiei nu este Peste 4.3. Asta a fost doar o pregatire de cand a fost update-ul mare al lui Xcode si oricum majoritatea aplicatiilor sau update-urile deja cer >4.3 tot din acelasi motiv.

  3. Pentru vechile aplicatii (tel, sms, mail, poze, net, calendar, skype) o sa fie inca fff bun 3G-ul :)
    Chiar si un 2G e inca bun ptr asa ceva 😉

  4. iOS 6 Beta 4 imbunatatire semnificativă a autonomiei bateriei fata de Beta 2 si 3… 6.20 ore usage si 17 ore standby cu 30% ramas…

  5. Mercedesul e tot Mercedes iphonul e tot iPhone indiferent de vârsta ! Nu cred ca sunt f putini cei care au un iPhone 3G .

  6. Curaj nu este chiar asa de rau daca va faceti deacuma provizii de aplicatii eu sunt detinatorul unui ipod touch 1g care il pot upgrada pana la ios 3.1.3 si incerc inca sa mai gasesc aplicatiile crackuite pentru acest ios sfatul meu faceti acelasi lucru cu aplicatii pana in ios 4.1.2 pana nu o sa le mai gasiti

    Nu va recomand instalarea aplicatiilor crackuite a retelelor de socializare

COMENTEAZA!