iOS 5 si situatia solutiilor de unlock

22

Ieri a fost o zi interesanta in care am aflat ca solutia de untethered jailbreak pe care o asteptam de mai bine de o luna si jumatate este deocamdata departe de a fi gata pentru o lansare publica dar am aflat totodata ca Dev Team ar fi gasit un exploit care ar putea fi transformat intr-o solutie de unlock numai pentru iPhone 4S. Da, in imaginea de mai sus avem o dovada nu prea convingatoare a faptului ca MuscleNerd ar fi reusit sa gaseasca un exploit care ar putea duce la dezvoltarea unei solutii de unlock dedicata exclusiv terminalului iPhone 4S insa nu si terminalului iPhone 4 sau a 3GS-ului.

iPhone 4S, iPhone 4 si iPhone 3GS au chip-uri baseband diferite deci pentru fiecare model trebuie gasit cate un exploit diferit in baseband iar acest lucru este extrem de greu de facut. Apple a reusit sa fragmenteze solutia de unlock aducand-o in situatia in care Dev Team trebuie sa isi tripleze eforturile pentru a produce o metoda de a decoda toate modelele de iPhone vandute acum si se pare ca ei se concentreaza pe cel mai important, iPhone 4S. Daca aceasta solutie de unlock va ajunge sau nu in mainile utilizatorilor in urmatoarele zile/saptamani/luni doar Dev Team stie insa cert este ca in momentul de fata nu exista vreo solutie de decodare pentru iPhone 4S.

Pentru iPhone 3GS/4 poate fi utilizat ultrasn0w pentru a decoda baseband-urile 05.13.x/06.15.00(iPhone 3G/3GS) sau mai mici dar si 01.59.x(iPhone 4). Pentru iPhone 4 mai exista o metoda de decodare folosind cartele Gevey 3G insa in cazul lor baseband-ul 04.10.01 este cel mai mare care poate fi decodat. Pe iOS 5 puteti decoda iPhone 3GS/4 cu ultrasn0w sau Gevey insa NUMAI daca faceti update folosind un custom ipsw si pastrati baseband-ul decodabil intact. Tutoriale care va invata sa faceti un custom ipsw gasiti aici.

In concluzie, Dev Team arunca promisiuni, este foarte departe de a oferi ceva viabil si terminalele factory unlocked sunt cea mai buna solutie pentru a scapa de problema decodarii.

UPDATE: ultrasn0w nu este compatibil cu iOS 5.0.1 deci nu incercati sa instalati aceasta versiune a iOS pentru ca nu veti putea face decodare.